Subject: Re: X weirdness (TGA2, AS600, -current)
To: None <>
From: Jarkko Teppo <>
List: port-alpha
Date: 04/11/2002 08:51:35
Roland Dowdeswell said:
> Could you send the exact dmesg lines that the TGA2 puts out so that I
> can make sure that our cards aren't too different?

I've got two different cards:

tga0 at pci0 dev 8 function 0: TGA2 pass 2, board type T8-02
tga0: 1024 x 768, 8bpp, Bt485 RAMDAC
tga0: interrupting at kn20aa irq 16
wsdisplay0 at tga0: console (std, vt100 emulation)

and (I haven't tested this with the AS600:

tga0 at pci0 dev 8 function 0: DC21030 step C, board type T8-02
tga0: 1280 x 1024, 8bpp, Bt485 RAMDAC
tga0: interrupting at kn20aa irq 16
wsdisplay0 at tga0 (kbdmux ignored): console (std, vt100 emulation)

The latter one has dip-switches accessible from the outside (ie. near
the VGA connector) while the first one doesn't. I can provide
chip/serial -numbers if needed. Oh yeah, I managed to get color, once.
With a .xinitrc containing only "exec xterm" and starting another
xterm with "xterm -bg red" gave me an xterm with red background.
After that all the other colors failed.

I also tried a few PC cards, Diamond Stealth 3D 2000 and ATI Rage II.
The Rage II wasn't recognized by SRM and the kernel sees it as
"not configured". A was a bit luckier with the Diamond (virge). I got
xf402.tar.gz from NetBSD/arch/alpha ... and after fighting with the
config-file I actually got it to work, sort of. It works with twm for
around five minutes and dies. The screen is not restored but I can still
type "shutdown -r now" (the control returns to wscons). Trying to start
xfce gives me this immediately.

Compiled XFree from fresh sources (with Simons patches from a year(!) ago):
(didn't apply cleanly, fixed the compilation though) and got the
same problems. I *have not* tried disabling acceleration. At this point
I was a bit tired and I seriously thought of fixing that stupid microswitch
on a date with Mr. Sledgehammer.

Thanks for all the help,