Subject: X weirdness (TGA2, AS600, -current)
To: None <>
From: Jarkko Teppo <>
List: port-alpha
Date: 04/09/2002 09:05:03

I just recently got an Alphastation 600 with a TGA2. I installed 1.5.2,
tried X and the console froze (white background, black text). Chanted
my -current mantra for a while and upgraded to 1.5ZA.

Now X works, sort of. If I run the XalphaNetBSD without -noaccel it leaves
junk on the sides of windows (like when I move an xterm-window). This
doesn't happen with -noaccel. The main annoyance I've got is with the
colors. Now xdpyinfo and friends all agree that I've got an 1280x1024 8bpp
display, but it sure doesn't look like that. It's black and white and
no amount of cursing or kicking brings out any colors. rgb.* are in the
correct place. Even if I specify colors with directly I still get only
black (or white, depending where the scale tips).

What makes this even weirder is that when running lynx on these black and
white windows the link cursor shows up (correctly) as red. SRM is white on
blue so it's not a monitor/cable/temporary-color-blindness -thing.

XalphaNetBSD is from the latest snapshot, kernel from three days ago.
TGA reports itself as 1280x1024 8bpp T8_02.

Any help appreciated. The 600 is a really nice workstation, I even
got wss0 working. NetBSD rocks :)