Subject: Ethernet problems on PWS 500au
To: None <>
From: None <>
List: port-alpha
Date: 10/02/2001 14:49:03

Today arrived my "new" used PWS 500au (1st generation motherboard). I
tried to install NetBSD 1.5.2 the usual way: netboot. I connected it to
my 100MB/s LAN, prepared the boot server (NetBSD/i386 1.4.2), swtitched
the alpha from ARC to SRM, "boot -protocols bootp ewa0" and the machine
booted without any problems up to the point where the kernel wants to
mount the NFS-root. Then I got timeouts from DHCP/BOOTP requests. I run
tcpdump on the boot server, but I could not see any packets. No lights
where blinking at the hub. First I thought the hub is "buggy" so I
connected the alpha via X cable and a two port Ethernet repeater to my
10MB/s LAN (coax). 

The same. Loading the first stage bootstrap and the kernel works well,
but the kernel can't get a single packet out of the physical interface.
So I booted the installation kernel with buld in mfs root. Again:
Netbooting works well but when the kernel is up nothing comes out of
de0. I fiddled around with ifconfig and the media flag, without

Finaly I installed via the net booted installation kernel and CDROM.
The machine is running now but I can't get the network interface to

Next try was to add an extra PCI card:
de1 at pci1 dev 10 function 0
de1: interrupting at dec 550 irq 20
de1: Cogent 21140A [10-100Mb/s] pass 2.0
de1: address 00:00:92:96:a7:79
and that is workling well. 

Any sugestions what is going wrong here are welcome. 

dmesg without extra de1:

NetBSD 1.5.2 (GENERIC) #37: Sat Aug 18 10:02:07 MEST 2001
Digital Personal WorkStation 500au, 500MHz
8192 byte page size, 1 processor.
total memory = 192 MB
(1992 KB reserved for PROM, 190 MB used by NetBSD)
avail memory = 170 MB
using 1229 buffers containing 9832 KB of memory
mainbus0 (root)
cpu0 at mainbus0: ID 0 (primary), 21164A-0 (unknown minor type 0)
cpu0: Architecture extensions: 1<BWX>
cia0 at mainbus0: DECchip 2117x Core Logic Chipset (Pyxis), pass 1
cia0: extended capabilities: 111<WLEN,MWEN,BWEN>
cia0: using BWX for PCI config access
cia0: WARNING: Pyxis pass 1 DMA bug; no bets...
pci0 at cia0 bus 0
pci0: i/o space, memory space enabled
de0 at pci0 dev 3 function 0
de0: interrupting at dec 550 irq 0
de0: DEC 21143 [10-100Mb/s] pass 3.0
de0: address 00:00:f8:75:99:6a
de0: enabling 10baseT port
--- schnipp ---