Subject: getting current, problems with __assert, etc
To: None <>
From: Caffeinate The World <>
List: port-alpha
Date: 06/24/2001 20:37:08
trying to get -current from 1.5s. i have the last snap from 05/15
installed. running into a few problems when trying to get apps to
compile. first, i get this:

  undefined reference to `__assert13'

so i tried to recompile /usr/src/lib/libc, then ran into this error:

building llib-lbz2.ln
Lint pass2:
all ===> libc
lint -chapbxzF -X 272 -D_LIBC -DNLS -DYP -DHESIOD -DLIBC_SCCS
src/lib/libc/include -DINET6 -D__DBINTERFACE_PRIVATE
-I/usr/src/lib/libc/dlfcn -DWITH_RUNE -DRUNEMOD_MAJOR=3
lint: illegal option -- X
Usage: lint [-abceghprvxzHF] [-s|-t] [-i|-nu] [-Dname[=def]] [-Uname]
        [-Idirectory] [-Ldirectory] [-llibrary] [-ooutputfile] file ...
       lint [-abceghprvzHF] [-s|-t] -Clibrary [-Dname[=def]]
        [-Idirectory] [-Uname] [-Bpath] file ...
*** Error code 1

make: stopped in /usr/src/lib/libc
*** Error code 1

make: stopped in /usr/src/lib

so i tried to compile lint

# make
all ===> lint1
cc   -o lint1 cgram.o scan.o mem1.o mem.o err.o main1.o decl.o tree.o
func.o init.o emit.o emit1.
o -ll
main1.o: In function `usage':
main1.c(.text+0x410): undefined reference to `getprogname'
main1.c(.text+0x414): undefined reference to `getprogname'
collect2: ld returned 1 exit status
*** Error code 1

please CC: me as i'm not on the list. thanks.

Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail