Subject: Kernel Panic caused by IPnat
To: NetBSD-Alpha Mailinglist <>
From: Andrew Garman <>
List: port-alpha
Date: 09/20/2000 14:04:05
The past week, I've been fighting to get my AlphaStation 200 up 
and running to replace my old 486 firewall (which unfortunately is
now too slow to meet my needs).

Today, I just put in two additional 3c905B cards and was looking 
forward to transitioning in the new system.  Everything looked up as
the ipfilter ruleset worked like a charm.  Unfortunately, when I 
tried to enable the minimal required ipnat ruleset, the system

I swapped back in the Generic kernel as I trimmed mine down to less 
than half the size.  The panic still occurs.  I did the same without
the ipfilter rules in place.  The panic still occurs.

AlphaStation 200, 233 Mhz w/ 80 MB RAM
de0 is the on-board DEC 21040 ethernet
ex0 is the first 3c905B ethernet
ex1 is the second 3c905B ethernet

I have the ex devices attached to my internal network and the 
de device directly attached to my outbound network device.

Aside from trimming the kernel, no other customization has been done.
Syslogd is the only network service running.

Any help would be greatly appreciated.  


Andrew Garman

# cat ruleset.nat
map de0 internal_net.0/24 -> my_ext_ip_here/32 portmap tcp/udp
map de0 internal_net.0/24 -> my_ext_ip_here/32
map de0 internal_net.0/24 -> my_ext_ip_here/32 proxy port ftp ftp/tcp
# ipnat -f ruleset.nat

fatal kernel trap:

    trap entry = 0x2 (memory management fault)
    a0         = 0x188
    a1         = 0x1
    a2         = 0x0
    pc         = 0xfffffc00003fb4fc
    ra         = 0xfffffc00003fb480
    curproc    = 0xfffffc0001032988
        pid = 195, comm = ipnat

panic: trap
Stopped in ipnat at     Debugger+0x4:   ret     zero,(ra)

Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.