Subject: Re: problem crosscompiling mipseb-netbsd on alpha
To: None <>
From: Izumi Tsutsui <>
List: port-alpha
Date: 05/24/2000 23:55:59
In <> wrote:

> I've been trying to compile a mipseb kernel on -current alpha. I've been
> unsuccesful here:

> /usr/pkg/cross/mipseb-netbsd/bin/cc -O2 -Wall -Werror
> -Wstrict-prototypes -Wmissing-prototypes  -Wpointer-arith
> -Wno-uninitialized -Wno-main -G 0  -mno-abicalls -mno-half-pic
> -I../../../../../../lib/libkern/arch/mips -I../../.
> -I../../../../../../arch -I../../../../../.. -nostdinc
> -I../../../../../../../gnu/sys -DSCSI_DELAY="0" -DMIPS3 -DMIPS3_5200
> ../../../../../../lib/libkern/sha1.c
> ../../../../../../lib/libkern/sha1.c: In function `SHA1Transform':
> ../../../../../../lib/libkern/sha1.c:115: virtual memory exhausted
> *** Error code 1

I try to make a newsmips kernel on my DEC3000/300, then
it also stalls at sha1.c and the kernel says
"pagedaemon: deadlock detected!"

But, IIRC, at the last time I tried to make a newsmips kernel
on alpha (before I committed cross-mipse[bl]-netbsd packages),
it just worked and the built kernel also worked fine. Hmm...
Izumi Tsutsui