Subject: boot pain
To: None <>
From: Joel N. Weber II <>
List: port-alpha
Date: 04/19/1999 04:07:11
I happen to be in the bizare situation that I have a machine which has
a mostly trashed root filesystem, yet the kernel image is intact, so I
would like to have the kernel mount an NFS root filesystem.

So I tried passing the N flag; the pelican I have that has a 1.3.3
GENERIC kernel prints this prompt:

root device (default sd0a): 

and then hangs.  If I type something, it isn't echoed, and hitting
enter has no effect.

The netbooting webpage also could usefully mention more device names;
the alpha I'm trying to get to boot apparently needs a command of the
form `boot ez0'.

When I run bootpd -s -d 4 on a nearby linux machine, I see this
output when I try netbooting:

bootpd: info(6):   recvd pkt from IP addr
bootpd: info(6):   bootptab mtime: Mon Apr 19 02:35:06 1999
bootpd: info(6):   request from Ethernet address 08:00:2B:38:76:2C
bootpd: info(6):   found (melange)
bootpd: info(6):   bootfile="/boot/"
bootpd: info(6):   vendor magic field is
bootpd: info(6):   sending reply (with no options)
bootpd: info(6):   setarp - 08:00:2B:38:76:2C

As near as I can tell, the alpha never actually tries to use tftp to
download the bootfile, though I can get it fine running tftp from the
command line of one of the working machines on the network.

Here's the output I see on the console:

>>> boot ez0
Host server IP address is


VECTOR   = 00000280
EXC_ADDR = 000BB258
PS       = 20000000.00001F00

R00 = 00000000.0000001F R01 = 00000000.00001F00 R02 = 00000000.0010ED08
R03 = 00000000.000FE770 R04 = 00000000.0016F0F0 R05 = 00000000.0016EE80
R06 = 00000000.00050E02 R07 = 00000000.00050E16 R08 = 00000000.00050A50
R09 = 00000000.00000001 R10 = 00000000.00050B44 R11 = 00000000.00050B44
R12 = 00000000.0000001D R13 = 00000000.00000011 R14 = 00000000.00000058
R15 = 00000000.00000004 R16 = 00000000.0000001F R17 = 00000000.00006000
R18 = 00000000.00000204 R19 = 00000000.00000000 R20 = 00000000.00050D47
R21 = 00000000.00000000 R22 = 00000000.00000000 R23 = 00000000.00000000
R24 = 00000000.00000000 R25 = 00000000.00000003 R26 = 00000000.000BB238
R27 = 00000000.001069C8 R28 = 00000000.00000001 R29 = 00000000.0016EDA0


The machine has no floppy drive; it would be helpful if peolpe would
either tell me how to get the machine to netboot, or else update the
documentation to describe some alternative to to netbooting or using a