Subject: Re: mount hangs
To: Ross Harvey <>
From: Ken Wellsch <>
List: port-alpha
Date: 03/30/1999 20:06:41
| From: Ross Harvey <>
| > From: Ken Wellsch <>
| > To:
| > Subject: mount hangs
| >
| > Since Saturday, I've been unable to get into multi-user on my AlphaPC164SX
| > with a new kernel built with source sup'ed each day (including today). 
| > I revert back to the kernel I built Thursday (Mar 25) and a user-land
| > built Wednesday (Mar 24).
| >
| > In single user, if I type "mount<cr>" it hangs with no output, and no
| > amount of keyboard activity can seem to get any attention save a break
| > into DB.
| >
| > I tracked it to the mount call used in mount_critical_filesystems in the
| > start-up rc stuff.
| >
| > With my old kernel, I get "root_device /dev/wd0a ...\n" from "mount."
| Hmm, we've been building kernels with no problems. Are you updating
| your /etc too? (I rarely do that, and the stock rc script has been
| churned a bit recently. It sounds like you might be running it. Is
| there an NFS or ifconfig dependency that's happening in the wrong
| order now?)

Yes I updated things that changed for /etc when I first encountered
this behavior.  I even rebuilt /bin/sh as that is part of the pipeline
in mount_critical_fs. Then I realized, if I just come up to single user
with a new kernel, and type "mount" what happens?  Hang.  Old kernel,
everything else the same, generates one line "root_device ..." and

| Does a new kernel work with the old userland?  An old mount with the
| otherwise new stuff?

I'm unable to bring userland up to today because I cannot run a new
kernel alas or at least get the "mount" command to not hang.  I did not
want to commit the sin of moving userland ahead of my working kernel.

I also tried recompiling mount too without success (as in it worked with
the Thursday kernel, but not any kernel built every day since Saturday).
Sorry I was putting -current on an ss20 on Friday so I can't say precisely
which day may have make the change.