Subject: netbooting multia - partial solution
To: UUCP <>
From: Tobias Ernst <>
List: port-alpha
Date: 03/10/1999 14:02:52

I previously posted about a problem when netbooting a Multia UDB. At that time
I had already managed to cope with the standard problems like "no hardware
address", but the bootstrap code was stuck right after being loaded by TFTP and
would not want to emit a single TCP/IP packet in order to load the kernel. At
this place I'd like to express special thanks to Roland Dowdeswell, who did
quite some debugging with me, but also could not find the problem.

I now have the solution: The problem was that I was using BNC thinwire Ethernet
with the Multia. After other operating systems also had problems with this (NT
autodetected a DEC Etherchip, but would not work unless I manually changed the
network adapter driver to a special driver called "DEC multia's Ethernet
controller", and a friend of mine did not get Debian Linux to talk using BNC,
while it worked with Twisted Pair), I organized a hub and two twisted pair
cables and tested the thing again, and -- using the bootstrap code from Rolands
Site with the "non-broken" setting -- it worked! Or at least, I managed to boot
the thing into single user mode :-).

For other reasons, I will be switching to Twisted pair soon (I am moving to a
new flat and have chose 100 MBit cabling for that one), so MY problem is
solved. But perhaps it is a good idea to look into the bootstrap code and
probably also the network driver and fix this.  From the fact that the NT "DEC
Chip" driver also works with Twisted Pair, but not with BNC, and that NT has a
separate driver vor Multia DEC ethernet cards, I guess that the multia hardware
somehow requires a special treatment (as opposed to other DEC ethernet cards)
when using BNC, while it behaves similar to other DEC ethernet cards when using
Twisted pair. (N.B.: Of course I tried to force BNC mode in the SRM console and
other things, it didn't help).

So be prepared for further questions from my side as soon as I have moved to
the new flat and will have other problems when setting up the rest of NetBSD

Kind Regards,