Subject: Re: Kernel compile: 1 bug, 1 hang
To: Frank Louwers <>
From: Eric Haszlakiewicz <haszlaki@UAccess.NET>
List: port-alpha
Date: 03/05/1999 02:03:32
> Thanks to all your great help, I am installing NetBSD on my UDB (still with
> the wrong resolution, I think it is a fault on the motherboard).
> When I tried to compile a new kernel, however, I run into 2 problems:
> The first one is that machine/pio.h doesn't exist! This file is #included in
> ad1814.c and wss.c, the sound drivers. I can comment out the #include, then
> the first one compiles without errors, but the second one won't compile.
	Hmm... a recent wss.c doesn't have pio.h in it.
I assume you're using 1.3.3?  The alpha hasn't had a pio.h for a while.
Perhaps this didn't work on the Alpha at the time of 1.3.3.
	What kind of errors are you getting?

> The second problem is much worse! The machine just hangs on the (final?)
> linking. The last line on the screen is:
> ld -N -Ttext fffff.. and so on.
	How much swap do you have configured?