Subject: Kernel compile: 1 bug, 1 hang
To: None <>
From: Frank Louwers <>
List: port-alpha
Date: 03/05/1999 08:19:51
Hi all,

Thanks to all your great help, I am installing NetBSD on my UDB (still with
the wrong resolution, I think it is a fault on the motherboard).

When I tried to compile a new kernel, however, I run into 2 problems:

The first one is that machine/pio.h doesn't exist! This file is #included in
ad1814.c and wss.c, the sound drivers. I can comment out the #include, then
the first one compiles without errors, but the second one won't compile.

The second problem is much worse! The machine just hangs on the (final?)
linking. The last line on the screen is:
ld -N -Ttext fffff.. and so on.

After that, nothing, you can't even telnet to it anymore!

Any suggestions?


|                    Frank Louwers (                       |
|                                                                            |
| Vice President                               System Administrator          |
| ZeusWPI - IT workgroup                       Master in Unix Administration |
|                                                    |
|                                                                            |
|      "Berkely brought us two things:                                       |
|       Unix and LSD. This is believed not to be a coincidence ..."          |
|                                                                            |