Subject: RE: /var/run vs /proc & newbie questions
To: Michael G. Schabert <>
From: Tim Rightnour <>
List: port-alpha
Date: 06/14/1998 01:36:27
On 14-Jun-98 Michael G. Schabert spoke unto us all:
# I noticed that things like weren't working, & the compiler stuff
# either. It was saying "wrong architecture". I eventually traced it down to
# the fact that there were 2 versions of certain commands, one in usr/bin,
# the other in usr/local/bin. The one in /usr/bin had the date Dec 10th,
# while the others were newer. Everything with the date Dec 10th that I have
# seen to date has been bad. Things with the date Dec 31st, though, have been
# OK. I had first installed 1.3.1 because when I first tried, Alpha didn't
# have an entry in 1.3.2, but I later installed the (then) latest snapshot
# (April 17th is the date on most stuff). I extracted the tarballs using the
# --unlink, but of course since the directory had been moved, it didn't
# remove the old stuff. Since the cmd hash table listed /usr/bin first, it
# couldn't read the updated files until I rm's the old ones. Was there a
# known issue with this, or was this a fluke?

I believe with 1.3.2 the practice of putting the toolchain in /usr/local was
stopped.  This probably caused you headaches, as it did me. (I spent all day
looking for bins in usr local going "where the !@#$ are they?!")

# In setting up ppp, though, I tried just using the pre-done scripts that the
# mac68k guys have. The scripts look for the pid of the pppd so that they can
# check for it, & so they can bring it down. Unfortunately, port-mac68k uses
# /proc for keeping them, whereas you guys use /var/run. Why would 2 ports of
# NetBSD have this difference? (all I can think of is that may be what OSF/1
# used). Which is the one that NetBSD is moving toward (if either)?

The pid files for pppd are stored in /var/run.  Thats how it is on all the
ports I use.  /proc, if it exists (read: make sure you mounted it!) will also
contain the pid info needed for pppd. (though I'd be interested to learn
exactly how it fetches the pid outta there)  I'll bet your mac has a /var/run
entry as well for it.

# OK, one last that I'm using an ethernet for the console, is it
# possible for me to use the ttyC0 for a regular serial? I have an ISDN line
# into my house, but unfortunately, my ISP doesn't let us use DOV on it, so
# that leaves me with a $0.01 per minute tariff whenever I want the speed.
# Luckily, though, most of my online usage isn't NetScape, so the speed is
# only needed every so often. Most of the time, I use my 14.4 modem on a POTS
# jack of the TA/NT-1. My goal, though, is to have the 14.4 on one serial
# port, & the TA on the other. I'll stay connected pretty much 24/7 via the
# analoog, but I'd like to make a "turbo-speed" command to (1) bring down
# pppd on ttyC1...(2) bring pppd up on ttyC0 (ISDN)...& be able to do my
# business, & then a quick "turbo-down" command to do the reverse. Am I
# dreaming or does this seem easy to accomplish? Can I put "none" in field 2
# of ttys for the ttyC0 and ttyC1 entries? Is it possible to tell it that the
# Ethernet network is all secure, but the PPP interface is not? Since it's a
# home LAN, I certainly won't be hacking into my own system, but the PPP
# connection is another story,although I really don't have anything worth
# worrying about on the alpha, & the Mac's secure in its own right.

EEEk!   Take that secure port out!!  If you want root accees, either add a user
to the wheel group, or use ssh to get into root.  Secure means "physically
secure".  As far as using a console port as a modem/isdn connection.. I'm not
actually sure how the SRM would cope with that.  If it detects a keyboard
missing, it places the console on the serial device.  It might not do so if you
manually overrode that.  But I would be skeptical. They do sell nifty little
"dummy keyboards" that are just little plugs that trick machines into thinking
a kbd is attached, if your SRM chokes on it.  You probably wouldn't need to
bring pppd down on port C1, you could most likely leave it up and manually
change the default routes back and forth in your script.

Tim Rightnour    -