Subject: Alpha problems
To: None <port-alpha@NetBSD.ORG>
From: Tim Rightnour <>
List: port-alpha
Date: 06/05/1998 15:54:42
With much help from Ross, I now am running NetBSD alpha/1.3E on my Multia.

My first task here, is to build tcsh, ssh, and then a new kernel.   However,
I'm getting some *really wierd* problems with this.

FYI- I installed the toolchain by doing:
cd /
tar --unlink -xzf /mnt/comp.132.tgz
tar --unlink -xzf /mnt/comp.snap.tgz

(if this was the cause of my problems)
Also.. I'm running the kernel from the kern.tgz in the snapshot.

First.. If I run ypbind.. it just hangs.. doesn't do anything, say anything,
talk to the network..   Just sits there and rots.  This is not due to the
-current snapshot.. It hung when I had 1.3 installed previously.

Tried to compile tcsh.  It began building, got to the first .c file, then
bombed out.  Said there was no /usr/libexec/cpp.  I copied it over, restarted
the build.  It then seemingly hung.  I suspended the build, and did a ps, to
find about *500* /usr/libexec/cpp 's being run.  Not wanting to trash my nice
new disk.. I killed the make and they all went away.

OK..  so I try ssh.  make fetch..  It connects to the server, then hangs and
times out.  So I ftp manually..  sure enough I can login, but I cannot issue
commands.  I'm going through ipnat here, and all the other hosts dont seem to
have a problem with this.

Manually get the files from another machine, execute make:
checking for gcc... cc
checking whether the C compiler (cc -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot
create executables.

Well thats no good.
Any help would be greatly appreciated.. I'm stumped.

Tim Rightnour    -