Subject: Re: multia tga display
To: Matthias Drochner <>
From: Chris G. Demetriou <>
List: port-alpha
Date: 02/23/1998 18:08:46
> Excerpts from netbsd: 22-Feb-98 multia tga display Joseph
> (2056*)
> > The wss driver won't build in the kernel due to a missing 
> > machine/pio.c i believe it was.
> That's one problem. Additionally, it doesn't compile without
> I've just fixed both in -current. Can somebody confirm that
> the driver actually works on the alpha?
> (If so, it should be pulled up to 1.3.x.)

I configured it into a kernel for an AlphaStation 500 and tried to
build.  Lo and behold:

13 [notunix] MAV % make
cc -g -O2 -Werror -Wall -Wstrict-prototypes -Wmissing-prototypes  -Wno-format -mno-fp-regs -I. -I../../../../arch -I../../../.. -nostdinc -DKTRACE -DDIAGNOSTIC -DDEBUG -DFIFO -DNFSSERVER -DINET -DCOMPAT_43 -DCOMPAT_10 -DCOMPAT_11 -DCOMPAT_12 -DCOMPAT_13 -DSYSVSHM -DMAXUSERS=8 -D_KERNEL  -Dalpha  -c ../../../../dev/isa/ad1848.c
../../../../dev/isa/ad1848.c:80: machine/pio.h: No such file or directory
*** Error code 1

8-)  However, commenting out _that_ include, the kernel makes and the
resulting binary boots and configures in the wss:

wss0 at isa0 port 0x530-0x537 irq 10 drq 0 drq2 1: CS4231A (vers 4)
audio0 at wss0

However, when i try to cat an audio file into /dev/audio, I don't seem
to get any output from the headphone jack or the machine's speaker.
The 'cat' process seems to be waiting on "aud wr", and when I finally
control-C it it goes to "aud dr" until it's done draining.  It seems
to me like it's not getting interrupts.

I tried all IRQs that I could set it to (as far as I know; 7, 9, 10,
11), and none worked.

p.s.: I checked in the ad1848.c change.  8-)