Subject: New kernel, no awd
To: None <port-alpha@NetBSD.ORG>
From: Ross Harvey <>
List: port-alpha
Date: 09/17/1997 17:08:08
I tried the new kernel on an eb164, the IDE drive appears to
configure correctly (same messages as a July kernel which
worked fine, as did kernels before that) but any attempt to
use it returns "device not configured".

  wd0 at wdc0 drive 0: <Conner Peripherals 1080MB - CFS1081A>
  wd0: 1032MB, 2097 cyl, 16 head, 63 sec, 512 bytes/sec
  wd0: using 16-sector 16-bit pio transfers, lba addressing

Try to use local IDE root:

  root device (default de0): wd0
  dump device (default wd0b): 
  file system (default ffs): 
  root on wd0a dumps on wd0b
  cannot mount root, error = 6

NFS root, try to fsck ide drive:

  Automatic boot in progress: starting file system checks.
  Can't open /dev/rwd0d: Device not configured

I'm using the same config file as before, with:

  isa*    at      sio?
  awdc0   at      isa? port 0x1f0 irq 14          # ST506/ESDI/IDE controllers
  awdc1   at      isa? port 0x170 irq 15
  awd*    at      awdc? drive ?

Any ideas?
Ross Harvey	Avalon Computer Systems, Inc.
		Santa Barbara