Subject: Re: xpm-3.4j and X11R6...
To: Feico Dillema <>
From: Greg Oster <>
List: port-alpha
Date: 04/21/1997 09:28:03 writes:
> In article <> Greg Oster <oster@cs.usa
>> writes:
>    Is anyone out there using the xpm-3.4j stuff on their NetBSD/alpha boxes (
> e.g. 
>    in fvwm or fvwm2).  If so, are the images/icons correct, or are they garbl
> ed?
> I had the same problem. I tried to track the problem down in the xpm
> source code despite my little knowledge on X-programming, and couldn't
> find the problem. Later I got when compiling xpaint and trying to exec
> it, the same failure as you described. I managed to get fvwm icons up
> and running, by hacking the icons. There's only a problem with the
> transparent icons. I just changed the background color of the icons
> from transparant to the background color I use most in fvwm. This was
> fine with me as a short-term solution, although a bit crippled.

Hmmmm... interesting....  I hadn't realized that it was just the transparent
icons that didn't behave.... Hmm..

>    In fvwm2, the many of the icons (like xterm.xpm and xv2.xpm) appear to be 
>    garbled. (some of the <columns> of the icons appear to be correct, but the
>    rest are just "noise").  Other icons (like world.xpm) work just fine
> transparant vs. non-transparant
>    When these applications are run on the alpha, and displayed on a
>    monochrome Sun3 X display, they work/display just fine :-( 
> I'm not sure on this, but I think I tried compiling xpaint on
> netbsd-i386 (1.2) and netbsd-alpha (>1.2), and that running them gave 
> the same problem on both. 

Hmm..  Was your primary display the alpha, or did you use the display on the 
i386 box?  

One other data point to add: I ran the "sxpm" program on a DEC Alpha running 
Digital Unix and on a Sun SPARC running SunOS.  When the DISPLAY was set to 
the NetBSD/Alpha box, both gave the exact same error:

     X Error of failed request:  BadLength (poly request too 
         large or internal Xlib length error)
     Major opcode of failed request:  72 (X_PutImage)

When the DISPLAY is set to one of our other boxes on campus, it works
"just fine".  My current belief is that the problem is hiding somewhere
in the Xserver or in the library routines called by the server... 


Greg Oster
Department of Computer Science
University of Saskatchewan, Saskatoon, Saskatchewan, CANADA