Subject: Re: xpm-3.4j and X11R6...
To: Greg Oster <>
From: Feico Dillema <>
List: port-alpha
Date: 04/21/1997 16:03:44
In article <> Greg Oster <> writes:


   Is anyone out there using the xpm-3.4j stuff on their NetBSD/alpha boxes (e.g. 
   in fvwm or fvwm2).  If so, are the images/icons correct, or are they garbled?

I had the same problem. I tried to track the problem down in the xpm
source code despite my little knowledge on X-programming, and couldn't
find the problem. Later I got when compiling xpaint and trying to exec
it, the same failure as you described. I managed to get fvwm icons up
and running, by hacking the icons. There's only a problem with the
transparent icons. I just changed the background color of the icons
from transparant to the background color I use most in fvwm. This was
fine with me as a short-term solution, although a bit crippled.

   In fvwm2, the many of the icons (like xterm.xpm and xv2.xpm) appear to be 
   garbled. (some of the <columns> of the icons appear to be correct, but the 
   rest are just "noise").  Other icons (like world.xpm) work just fine.
transparant vs. non-transparant

   When these applications are run on the alpha, and displayed on a monochrome 
   Sun3 X display, they work/display just fine :-( 
I'm not sure on this, but I think I tried compiling xpaint on
netbsd-i386 (1.2) and netbsd-alpha (>1.2), and that running them gave the same
problem on both. 

   I'm planning on looking further into this after the weekend, but in the 
   meantime I figured I'd ask if anyone else has seen this problem...

   I'm running NetBSD-current as of March 5th or so (ELF, shared libs, vm fixes, 
   etc), with the "x11-fixes.tar.gz" X11 shared libraries.  The alpha is a 
   Multia, for as much as that should matter.
I have a similar system and similar problems.