Subject: Re: nfs mount doesn't work
To: Charlie Root <>
From: Chris G Demetriou <Chris_G_Demetriou@UX2.SP.CS.CMU.EDU>
List: port-alpha
Date: 03/21/1996 12:38:28
> I run the 960224 distribution and experience problems when trying to
> nfs mount a partition.
> 	hotdog  ------ ether ------ dingo
> Hotdog can nfs mount a partition from dingo, but dingo can't nfs mount
> a partition from hotdog. When issuing the following command on dingo 
> the process hangs until crtl-c is issued.

I could believe this; the NFS code changed significantly (nfsv3
support) in the last distribution.  I'm not sure that I ever tried
mounting an NFS partition exported from a NetBSD/Alpha with the new
NFS code.

What kind of host is 'dingo'?

I'm not going to have time to debug this -- or probably even look at
it -- until at least the second week of april.  I've got a lot to do
in the rest of this month, a bit of travel scheduled for the beginning
of April, and i've yet to actually convert the Alpha port to use the
new <machine/bus.h> interfaces now used by various i386 drivers.
(sort of ironic that me designing them to allow the alph and i386
drivers to be merged would cause me a lot of pain, but that's the pain
of trying to get the alpha kernel changes merged back into the

If you're interested in trying to debug this, i'd suggest looking for
wrong-looking uses of 'long' at various places in the code path that
might make a difference: mountd, portmap, nfs kernel code.