Subject: "multia" AXPpci machine?
To: None <port-alpha@NetBSD.ORG>
From: Arne H. Juul <>
List: port-alpha
Date: 03/03/1996 05:47:02
   Recently we've received for testing a new lowend Digital
Alpha-based PC named a "multia".  (I don't know if this offer is so good
compared to your garden variety PC, but it's low enough to be interesting:
DEC chip 21066-166 Mhz CPU, 256 Kbyte Cache, 16 Mb memory, 1,44 Mbyte
floppy, 1 Gigabyte SCSI disk, Ethernet controller (combo), Mouse and
keyboard - $1500 + vat)

   The machine can run (according to the salesman) NT, Digital Unix or
Linux, and it was actually preinstalled with linux when received.
I have to say, linux seemed to work quite OK, including
running X11 server and varoious other programs very well.
But of course, I wanted to see if NetBSD could run on the box instead.
Hopefully, the machine should be compatible with Alphastation or
AXPpci machines:  It has PCI bus, standard PCI scsi card (ncr53c810),
probably PCI VGA card, PCI ethernet.

So far I've just tested taking a disk, dd-ing in the binary
snapshot rz25-image.gz, version 960224.  Then I went to SRM
console and booted with "boot dka300".  This produced some
messages about finding the boot block and then immediately
returned to the SRM prompt.  I also tried "boot -file netbsd dka300"
with the same result.

However, I read in the STATUS file that I should first
get a serial console.  I don't have the cables etc. for that
right now, but I could probably get if it would help.  So,
the questions are:

1) are there good chances this machine will run NetBSD now
   or in the near future?  I append to this mail the boot-time
   output from linux in case that helps.
2) do I really need to use a serial console?  The STATUS file
   also lists that PCI VGA video board are supported, so I'm
   a bit confused.
3) is anyone working on X11 server support for NetBSD/alpha?
4) should I just forget NetBSD/alpha for now and just test the
   box with linux?  Linux/alpha seems (after reading the NetBSD
   port-alpha list for a while, and now testing the linux variant)
   to be much more mature, but this may of course be false.

Your friendly NetBSD fanatic,

  -  Arne H. J.

[cat /proc/kmsg after boot:]

<5>Console: 16 point font, 400 scans
<5>Console: colour TGA 80x25, 1 virtual console (max 63)
<5>Alpha PCI BIOS32 revision 0.03
<5>Probing PCI hardware.
<5>Calibrating delay loop.. ok - 164.63 BogoMIPS
<5>Memory: 22920k available
<5>Swansea University Computer Society NET3.033 for Linux 1.3.38
<5>NET3: Unix domain sockets 0.10 BETA for Linux NET3.031.
<5>Swansea University Computer Society TCP/IP for NET3.032
<5>IP Protocols: ICMP, UDP, TCP
<5>Linux version 1.3.43 ( (gcc version 2.7.0) #4 Wed Nov 22 14:35:21 EST 1995
<5>Serial driver version 4.11 with no serial options enabled
<5>tty00 at 0x03f8 (irq = 4) is a 16550A
<5>tty01 at 0x02f8 (irq = 3) is a 16550A
<5>lp0 at 0x03bc, (polling)
<5>PS/2 auxiliary pointing device detected -- driver installed.
<5>Sound initialization started
<5>snd24 <MS Sound System (CS4231A)> at 0x530 irq 9 drq 3
<5>Sound initialization complete
<5>Floppy drive(s): fd0 is 2.88M
<5>FDC 0 is a post-1991 82077
<5>scsi-ncr53c7,8xx : at PCI bus 0, device 6,  function 0
<5>scsi-ncr53c7,8xx : NCR53c810 at memory 0x11000000, io 0x10100, irq 11
<5>scsi0 : using io mapped access
<5>scsi0 : using initiator ID 7
<5>scsi0 : using edge triggered interrupts
<5>scsi0 : burst length 8
<5>scsi0 : using 40MHz SCSI clock
<5>scsi0 : NCR code relocated to 0xfffffc000001a3b0
<5>scsi0 : test 1 started
<5>scsi0 : NCR53c{7,8}xx (rel 4)
<5>scsi : 1 host.
<5>  Vendor: TOSHIBA   Model: MK2326FB          Rev: A15B
<5>  Type:   Direct-Access                      ANSI SCSI revision: 01 CCS
<5>Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
<5>scsi : detected 1 SCSI disk total.
<5>SCSI Hardware sector size is 512 bytes on device sda
<6>PPP: version 2.2.0 (dynamic channel allocation)
<6>TCP compression code copyright 1989 Regents of the University of California
<6>PPP Dynamic channel allocation code copyright 1995 Caldera, Inc.
<6>PPP line discipline registered.
<5>eth0: DE435 at 10000 (PCI bus 0, device 8), h/w address 08:00:2b:e4:d6:27,
<5>      and requires IRQ10 (not probed).
<5>de4x5.c:v0.32 6/26/95
<5>Partition check:
<5>  sda: sda1 sda2 sda3
<5>VFS: Mounted root (ext2 filesystem) readonly.
<5>eth0: Searching for media... media is TP.