pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

jupyter notebook with R kernel


Has anybody tried to run a jupyter notebook with R kernel? I tried a
few times, always getting:
An irrecoverable exception occurred. R is aborting now ...
[I 10:35:45.989 NotebookApp] KernelRestarter: restarting kernel (4/5),
new random ports
                             During startup - Warning message:
Setting LC_COLLATE failed, using "C"

 *** caught segfault ***
address 0x2a8, cause 'memory not mapped'

 1: toupper(nms)
 2: is.factor(x)
 3: gsub(".", "_", toupper(nms), fixed = TRUE)
 4: opt_to_env(opt_name)
 5: init_options()
 6: fun(libname, pkgname)
 7: doTryCatch(return(expr), name, parentenv, handler)
 8: tryCatchOne(expr, names, parentenv, handlers[[1L]])
 9: tryCatchList(expr, classes, parentenv, handlers)
10: tryCatch(fun(libname, pkgname), error = identity)
11: runHook(".onLoad", env, package.lib, package)
12: loadNamespace(x)
An irrecoverable exception occurred. R is aborting now ...
[W 10:35:49.009 NotebookApp] KernelRestarter: restart failed
[W 10:35:49.009 NotebookApp] Kernel
7ae6af18-8b75-4bfe-b3fc-b22451233b38 died, removing from map.

At the same time python (3.9) kernel works fine (I even tested wip/py-plotly).



Home | Main Index | Thread Index | Old Index