pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pango build errors

Was I glad to see that --- I have been having that particular error
for some time now and thought that was some local problem.

On Wed, 21 Apr 2021 at 06:28, Mayuresh <> wrote:
> On Wed, Apr 21, 2021 at 08:24:20AM +0530, Mayuresh wrote:
> > WARNING: Found CMake '/usr/local/netbsd/work/devel/pango/work/.tools/bin/false' but couldn't
> > run it
> > Found CMake: NO
> > Run-time dependency fontconfig found: NO (tried pkgconfig and cmake)
> > Run-time dependency fontconfig found: NO (tried pkgconfig and cmake)
> > Looking for a fallback subproject for the dependency fontconfig
> >
> > ERROR: Neither a subproject directory nor a
> > fontconfig.wrap file was found.
> Following errors are seen in work/pango-1.48.4/output/meson-logs/meson-log.txt
> Pkg-config binary for MachineChoice.HOST is not cached.
> CMake binary for MachineChoice.HOST is not cached

I suspect some (but not all) of the current pkgsrc problems to come
from the recent switch to gcc10 - which was expected; I found already
a few packages I had to modify, e.g. adding some
'-Wno-error={something}' to the CFLAGS. The strange thing is, my first
pkg_rolling-replace since the gcc upgrade was rather good - only some
10 packages weren't built and I was able to fix them manually - see
below some of the 'methods' I used; however, my latest overnight
pkg_rolling-replace run was much less successful; I am still to
examine the reasons for that.

In your other message you mention about a freetype2 include file not
been found - I get similar all time, regarding freetype2, fontconfig,
gl/egl and others. I haven't been able to find out the core reason,
what I do now fixes the build, but obviously not the problem. When I
get a similar error, I manually add the needed links to the .buildlink
and .x11-buildlink trees, e.g.

cd work/.buildlink
cd include
ln -s /usr/pkg/include/KHR .
[[ -d GL ]] && rm -r GL
mkdir GL
cd GL
ln -s /usr/pkg/include/GL/* .
cd ..
ln -s /usr/pkg/include/EGL .
cd ../lib
rm libGL*
ln -s /usr/pkg/lib/libGL* .
ln -s /usr/pkg/lib/libEGL* .
cd pkgconfig
rm gl.*
ln -s /usr/pkg/lib/pkgconfig/egl.pc .
ln -s /usr/pkg/lib/pkgconfig/gl.pc .


 cd work/.buildlink/include
 ln -s /usr/pkg/include/freetype2 .
 ln -s /usr/pkg/include/fontconfig .
 cd ../lib
 ln -s /usr/pkg/lib/libfreetype.* .
 ln -s /usr/pkg/lib/libfontconfig.* .
 cd pkgconfig
 ln -s /usr/pkg/lib/pkgconfig/freetype2.pc .
 ln -s /usr/pkg/lib/pkgconfig/fontconfig.pc .

(the above may help you).

or something like that. My latest weird problem is with x11/gtk4 -
while I was able to come to a successful 'make' using similar to the
above, I got a PLIST error in 'make package' - as the output directory
contained a long list of files obviously from packages already present
in the system (x11/gtk4 build in my case at least pulls the source of
several already installed common packages during build).

I haven't asked the list or sent any PRs as there are quite a few wip
packages in this build host, so I've always thought this is my local

> --
> Mayuresh



Home | Main Index | Thread Index | Old Index