pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [EXTERNAL] Re: Interaction between lang/gcc10 and archivers/zstd

Intersting. I uninstalled the gcc10 package made with --without-zstd, removed the package from the packages/ directory and tried to reinstall with a clean Makefile. As I expected, it failed with the same issue.

Were any other packages installed between your unsuccessful and successful installs? I'm wondering if one of the tools used during configuration is a factor.



On 2/3/21, 03:11, "Chavdar Ivanov" <> wrote:

    I had zstd installed; I just tried gcc10. I don't know why, I never
    looked at the log file, but the first 'make' in lang/gcc10 with the
    default settings (under amd64 -current from today) failed; subsequent
    'make' with no changes whatsoever completed without any problems.


    On Wed, 3 Feb 2021 at 05:57, Morgan, Iain (ARC-TN)[InuTeq, LLC]
    <> wrote:
    > Hello,
    > As I mentioned in my previous email, there is a somewhat strange issue building lang/gcc10 on both CentOS 7 and RHEL 7. However, the problem does not occur on SLES 15.
    > The problem is that if archivers/zstd is already installed, the GCC build detects the headers and tries to build LTO bytecode compression support using zstd. But, it fails to link against the library and there are a number of errors regarding undefined references to various zstd-related symbols.
    > The issue can be avoided by either ensuring that lang/gcc10 is installed prior to archivers/zstd or by adding --without-zstd to CONFIGURE_ARGS for lang/gcc10.
    > Since SLES 15 provides more recent utilities, including GCC 7.5, it seems to avoid this issue.
    > I should note that I tried including the  file from archivers/zstd in the lang/gcc10 Makefile, but that did not address the problem.
    > --
    > Iain Morgan


Home | Main Index | Thread Index | Old Index