pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

issue with squid

i'm having issues in obtaining a squid install

starting from a fresh installed netbsd9.1 / i386
i tried with pkgin but such a squid binary was not found.
So i tried to compile it
both with 2020Q3 or current

make fails with

checking for shl_load in -ldld... (cached) no
checking for dld_link in -ldld... (cached) no
checking what kind of compiler we're using... gcc
checking for compiler variant... gcc
checking whether compiler requires -Werror -Wno-deprecated-register... no
configure: inlining optimizations enabled: yes
configure: cbdata debugging enabled: no
configure: xmalloc stats display: no
checking whether linking without -latomic works... no
checking whether linking with -latomic works... no
configure: error: Required library libatomic not found.
*** Error code 1

installing devel/libatomic and devel/libatomic_ops does not help the makefile.

could you please advise?


Home | Main Index | Thread Index | Old Index