pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

obsolete graphics/vtk


I tried to build wip/freecad after locally modifying the package to
refer to the released version 0.18.4 and manually running cmake in the
resulting directories. This, among other things, showed that I had to
install graphics/vtk, which I did; however, freecad requires at least
version 6 of vtk, whereas the pkgsrc version is 4.2.6.

I then tried to locally modify this package to use the latest released
version, which is 9.0.1. Obviously the existing patch set - from 2006,
2007 - was useless for this, so I just ran cmake in a build directory.
After some three minor changes - a C++ cast, a missing'


 in one of the tools subdirectories  and one other, the build process completed.

I am stuck with the building of the package, though ('make package'
tries to open the Makefile in the working directory, but this is
located in a subdirectory of the latter - I am sure my limited pkgsrc
knowledge is to blame here).

I wonder if somebody could have a look, it seems fairly low hanging
fruit. The build was attempted on a very recent amd64 -current system.



Home | Main Index | Thread Index | Old Index