pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Bootstrap failure on OS X Catalina

Rob Whitlock <> writes:

>> On Sep 28, 2020, at 9:03 AM, Greg Troxel <> wrote:
>> Rob Whitlock <> writes:
>>> Running ./bootstrap --unprivileged ends with
>>> bmake: no system rules (
>>> How should this be corrected? My understanding is that pkgsrc already
>>> contains bmake and whatever rules it needs to work. Here is the full
>>> output:
>> Two things:
>>  make sure you are testing with up-to-date HEAD or 2020Q3.  tell us
>>  which.  do 'cvs update' to be sure there are no changes in your tree,
>>  or the equivalent in whatever tool you are using
>>  tell us what you have installed in terms of XCode and/or Command Line
>>  Tools
> I downloaded <>
> from the link on the web page <> under "get pkgsrc". I
> did a cvs update just now, and bootstrap errored out with the same
> error. (I ran cleanup first)

That sounds like the right thing.

> pkgutil(1) seems to give a version of for the
> Command Line Tools. Xcode is not installed.

That is a configuration  that we intend should work, but I am not sure
anyone else has tried it yet.   I hope one of our macOS experts chimes
in.  (I do not have machine running macOS 10.15.)

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index