pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

[2019Q3] Cannot build libkexiv2


	I have upgraded my pkgsrc tree (NetBSD 8.1_STABLE) and done
pkg_rolling-replace -suv to upgrade all installed packages.

	As usual, I have to fix some minor issues but I'm unable to build

-- Could NOT find Exiv2: Found unsuitable version "..", but required is
at least "0.24" (found /usr/pkg/lib/
CMake Deprecation Warning at
/usr/pkg/share/cmake-3.15/Modules/FeatureSummary.cmake:669 (message):
  SET_PACKAGE_INFO is deprecated.  Use SET_PACKAGE_PROPERTIES instead.
Call Stack (most recent call first):
  CMakeLists.txt:28 (MACRO_LOG_FEATURE)

-- The following REQUIRED packages could NOT be located on your system.
-- You must install these packages before continuing.
   * Exiv2 (0.24 or higher)  <>
     Required to build libkexiv2.


	I don't understand why cmake aborts with :
'Exiv2: Found unsuitable version ".."' Of course, exiv2 is installed:

legendre# pkg_info exiv2
Information for exiv2-0.27.2:

	I have seen some build issues like
but no one is able to fix this failure.

	Help will be welcome.

	Best regards,


Home | Main Index | Thread Index | Old Index