pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Strange circular dependency on Linux Mint 19.2 (partially solved)

On Wed, 28 Aug 2019 11:15:57 +0200
Gmail <> wrote:

> Hi All,
>         When trying to compile "libtool" on Linux Mint 19.2
> (the last version), I get a strange problem of circular dependency.
> The last stable version of PKGSRC is used.
> This is a big problem since without libtool almost no
> package can be compiled.
> The proble arise when compiling "nbpatch". The dependency seems
> to be about "gcc3" (why a such old version of gcc?).
> Do you have an idea?

Hi all,
     This was a problem due to a mess in my config.
Removing pkgsrc and pkg and reinstalling everything
from scratch solved the problem.

However to compile libtool, one has to compile libtool-fortran.

libtool-fortran depends on g95.

Finally g95 seems to use an old version of gcc (gcc 4.2.1) which is
a 32bits executable (at least it is compiled as a 32bits app for g95).

In Linux Mint 19.2 (based on Ubuntu 18.04 LTS) nothing
is installed to compile 32bits apps.

One has to pass the command "apt-get install gcc-multilib" to install
all the headers files and libraries to compile 32 bits apps.

Finally the compilation of gcc 4.2.1 starts but fail with
an error message about dereferencing an incomplete pointer.

Searching the Web shows that this error is quite
common but I have found no patch for this version
of gcc.

Do you have any idea?

-------------------------------end of the log of the failed compilation-------------
/opt/pkgsrc/lang/g95/work/gcc-4.1.2/g95/./gcc/xgcc -B/opt/pkgsrc/lang/g95/work/gcc-4.1.2/g95/./gcc/ -B/opt/pkg/x86_64-debian-linux/bin/ -B/opt/pkg/x86_64-debian-linux/lib/ -isystem /opt/pkg/x86_64-debian-linux/include -isystem /opt/pkg/x86_64-debian-linux/sys-include -O2  -O2 -O2 -D_FORTIFY_SOURCE=2   -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -I. -I. -I../../gcc -I../../gcc/. -I../../gcc/../include -I../../gcc/../libcpp/include  -fexceptions -fvisibility=hidden -DHIDE_EXPORTS -c ../../gcc/unwind-dw2.c -o libgcc/./unwind-dw2.o
In file included from ../../gcc/unwind-dw2.c:256:
../../gcc/config/i386/linux-unwind.h: In function 'x86_64_fallback_frame_state':
../../gcc/config/i386/linux-unwind.h:58: error: dereferencing pointer to incomplete type recipe for target 'libgcc/./unwind-dw2.o' failed
make[3]: *** [libgcc/./unwind-dw2.o] Error 1
make[3]: Leaving directory '/opt/pkgsrc/lang/g95/work/gcc-4.1.2/g95/gcc'
Makefile:1436: recipe for target 'stmp-multilib' failed
make[2]: *** [stmp-multilib] Error 2
make[2]: Leaving directory '/opt/pkgsrc/lang/g95/work/gcc-4.1.2/g95/gcc'
Makefile:3905: recipe for target 'all-gcc' failed
make[1]: *** [all-gcc] Error 2
make[1]: Leaving directory '/opt/pkgsrc/lang/g95/work/gcc-4.1.2/g95'
Makefile:615: recipe for target 'all' failed
make: *** [all] Error 2
*** Error code 2

bmake[1]: stopped in /opt/pkgsrc/lang/g95
*** Error code 1

bmake: stopped in /opt/pkgsrc/lang/g95

Home | Main Index | Thread Index | Old Index