pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bind 9.12 vs bind 9.14

 Dear pkgsrc-users,

I'm writing to this list because is listed as the maintainer for the bind912 and bind914 packages. Please, forward as appropriate.

I noticed that the bind912 package is now marked deprecated (eol) and that we should all upgrade to bind914.

I've been watching and trying bind914 for a while and never got past a
problem I'm having with with a simple 'rndc status' command hanging with bind-9.14.2 but working fine with bind 9.12.4-P1.

I'm running the exact same configurations with both packages.
If I run /usr/pkg/sbin/rndc with -V, either versions coming with bind, when run against a bind 9.14.2 server, it hangs after 'send message'. When run against a bind 9.12 server, it immediately receives a response and logs 'parse message' and completes the request.

I've had no other issue with bind 9.14, my dns server seems to work just fine in all other aspects (at least it's running as well as with bind 9.12.4-P1). I just can't get it to respond to rndc (!).

Is there anything incompatible between the configs that I need to change for bind 9.14 ? I've looked and looked and looked on Google and I see no issues like mine with rndc just handing after 'send message' (my keys setup works, for example). I've also tried to increase logging levels but could not get any output into the logs triggered by rndc sending messages to the server.

Thank you for your assistance !


Home | Main Index | Thread Index | Old Index