pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

[SOLVED] Re: ebook-viewer dumps core on the stable branch

I solved it. Pilot error in this case.

I had some old X libraries around on this computer's /usr/X11R7/lib
directory, from earlier attempts to partially upgrade it. (For reasons
of a bug that manifested with left-handed mice and gtk3; I think I wrote 
about that before).

The clue was:
> #0  0x00007e891d977450 in _X11TransWritev () from /usr/X11R7/lib/

where libX11 is supposed to be version 7, not 6...

Removing a bunch of old files helped. It also helped my troubles with
vlc; it doesn't crash at startup anymore but as usual after almost 30

How a library with the wrong major number got loaded, I'm not sure.
One aspect may be that a whole bunch of libraries were loaded at runtime
into python as part of the PyQt package.

And how does one use the files in the (x)debug.tgz sets with gdb? I
tried passing them with gdb -s, or with (gdb) add-symbol-file, but
neither worked.

___ Olaf 'Rhialto' Seibert  -- "What good is a Ring of Power
\X/ rhialto/at/      -- if you're Speak." - Agent Elrond

Attachment: signature.asc
Description: PGP signature

Home | Main Index | Thread Index | Old Index