pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems distributed pbulk

Well... nobody's using master_mode ?

On Mon, Jul 23, 2018 at 3:27 AM Julien Savard <> wrote:
I'm trying to setup a distributed pbulk on 2-3 netbsd nodes. All are dedicated to pbulk so I did not make any sandboxes. I did make 2 NFS shares which are on a Linux server. One contains /usr/pkgsrc including distfiles and packages directory that is mounted on /usr/pkgsrc. The other is mounted on /usr/pbulk. It contains the pbulk bootstrap ( binaries and scripts ). 
I created the ssh keys and exchanged it between hosts as root.
When ruiing pbulk with "master_mode = off" ( and with a limited list of 1 package) everythings works well.
However when I switch master_mode on I always get this error :

nbqc1-sparc5# /usr/pbulk/bin/bulkbuild     
Warning: All log files of the previous pbulk run will be
removed in 5 seconds. If you want to abort, press Ctrl-C.
Removing old scan results
Using old scan results from /var/log/pbulk.old/meta/pscan
pbulk-scan: Invalid path from master

It does not really crash but it simply hang there unless I kill it.
I first tried with master_ip as the NIC ip ( 192.168.X.Y ) and with scan_clients and build_clients with the clients IP.
I then canged scan_clients and build_client to the same IP as master_ip ( just to be sure it wasn't network related )
And finaly even tried with
Always the same error...
Oh and yes from the begining master_port_scan/buid is uncommented with the default value.
Running a "ps" on anoter terminal during the error gives me this :

nbqc1-sparc5# ps -aj| head -1; ps -ajww | grep bulk             
root  4339 29044  4339 71b6c8    1 I+   pts/0 0:00.10 /bin/sh /usr/pbulk/bin/bulkbuild 
root  7861  4339  4339 71b6c8    1 I+   pts/0 0:00.09 /bin/sh /usr/pbulk/libexec/pbulk/scan 
root 12932  7861  4339 71b6c8    1 I+   pts/0 0:00.07 /usr/pbulk/bin/pbulk-scan -v -l -I /usr/pbulk/libexec/pbulk/scan-client-start -m -M /usr/bin/make /usr/pkgsrc /var/log/pbulk/meta/pscan 

All paths in pbulk-scan seems OK exept /var/log/pbulk/meta/pscan which is not present. Creating it is useless because it will be removed the next time I run a bulkbuild

Tried to google search the error, look for a verbose switch or an interesting log file but nothing...

I'm a little out of idea, Can anyone can help me or at least point me in the right direction ?

Home | Main Index | Thread Index | Old Index