pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problem compiling cmake

Hello folks.  I'm running Current, (8.99.22), for amd64.  I tried to update the pkgsrc programs on Friday, 27, 2018.  Everything worked expect cmake-3.12.0. 

It seems that it does all the compilation properly, then as it's running install, it crashes at the very end with this message:

-- Installing: /usr/pkgsrc/devel/cmake/work/.destdir/usr/pkg/share/cmake-3.12/completions/cpack
-- Installing: /usr/pkgsrc/devel/cmake/work/.destdir/usr/pkg/share/cmake-3.12/completions/ctest
=> Automatic manual page handling
=> Generating post-install file lists
pkg_create: can't stat `/usr/pkgsrc/devel/cmake/work/.destdir/usr/pkg/bin/ccmake'
=> Checking file-check results for cmake-3.12.0
ERROR: ************************************************************
ERROR: The following files are in the PLIST but not in /usr/pkgsrc/devel/cmake/work/.destdir/usr/pkg:
ERROR:         /usr/pkgsrc/devel/cmake/work/.destdir/usr/pkg/bin/ccmake
*** Error code 1

make[1]: stopped in /usr/pkgsrc/devel/cmake
*** Error code 1

make: stopped in /usr/pkgsrc/devel/cmake

I don't know what happened to "ccmake", but it's not there.  Appreciate if you could take a look.  Thanks.

Home | Main Index | Thread Index | Old Index