pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libuv i386 build failure

On Tue, 19 Sep 2017, Patrick Welche wrote:
On Tue, Sep 19, 2017 at 07:55:41AM -0500, Michael Parson wrote:

  $ perl -v

  This is perl 5, version 26, subversion 0 (v5.26.0) built for x86_64-netbsd-thread-multi

Didn't get as far as running configure, which is where I would have
expected loads of "if test"...


Looks like we're going to have to go around escaping '{' to keep
stuff working, kinda like we had to do to the '@' char back in the
perl4->perl5 days.

File a bug upstream?

This is going to be "interesting": I just compiled libuv successfully
on -current/amd64, i.e., the same perl as you. So we have,

-current/amd64  success
-current/i386   fail
6.1/amd64       fail

I hadn't actually tried to build libuv, I was just reporting what I'd
seen in another application giving a similar error.

FWIW, I just tried libuv-1.12.0 and it came out clean, no references to
that perl warning/error at all.

Michael Parson
Pflugerville, TX

Home | Main Index | Thread Index | Old Index