pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem building on LinuxMint (Ubuntu)

Noticed the changes to PATH and thought that might be my problem.  Just to make sure I started with a completely clean LinuxMint installation and did this all under root:

apt-get install cvs libncurses5-dev gcc g++ zlib1g-dev zlib1g libssl-dev libudev-dev bmake

modified my environment to include:
	export SH=/bin/bash
	PATH=“/usr/pkg/sbin:/usr/pkg/bin: …

downloaded pkgsrc
	cd /usr
	cvs checkout pkgsrc

did the bootstrap
	cd /usr/pkgsrc/bootstrap

Then tried to build pkg_chk with:
	cd /usr/pkgsrc/pkgtools/pkg_chk
	bmake install

Same results, here is the log file:

Attachment: typescript
Description: Binary data

So I’m at a loss.

On May 4, 2017, at 7:40 AM, Jonathan Perkin <> wrote:

> * On 2017-05-04 at 13:27 BST, Robert Nestor wrote:
>> Not sure I understand your comment “need to use bmake when bootstrapping”.  Does the bootstrap script try to use bmake to bootstrap and thus my installation procedure needs to install bmake BEFORE i do the bootstrap?  Since bmake isn’t included in the LinuxMint/Ubuntu base system after I install it any place it will be used should always get the same copy.
> No, I meant that when you are using bootstrap (as opposed to using the
> native make on NetBSD) then you need to use bmake.  It was in response
> to your "Linux make doesn't work" comment.  No make other than the one
> you have bootstrapped will work for building packages.
>> Anyway, I cleaned out all the work directories and tried building again.  Here’s the complete log file, but I’m not sure it contains any other error messages.  If it does I missed them when I scanned the file.
> There's something seriously wrong, as the entire build step is being
> skipped:
>  ===> Building for cwrappers-20170112
>  => Unwrapping files-to-be-installed.
> There should be the build of the cwrappers software in between those
> two lines.
> Not sure what's causing that.  Bad timestamps?  Something toxic in
> your environment that conflicts with pkgsrc, e.g. BUILD_DIRS?  Try in
> a clean environment, e.g.
>  $ env -i bash --norc --noprofile
>  $ PATH=/usr/pkg/sbin:/usr/pkg/bin:$PATH
>  $ cd pkgsrc/pkgtools/cwrappers
>  $ bmake clean; bmake install
> then if that works go through the differences until you find what's
> causing the problem.  Change /usr/pkg if you used a different --prefix
> argument to ./bootstrap
> -- 
> Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index