pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Failures on NetBSD/macppc 6.0 for pkgsrc-current


in anticipation of 2016Q4 I recently spun up a bulk build of
pkgsrc-current for NetBSD/powerpc on a macppc running 6.0 (yes, I
know 6.0 is old, but my 7.0 host developed a bad disk, and I've
not gotten around to replacing it and reinstalling 7.0 yet...),
and I've already struck a few failures:

[918/17510] Starting build of  cmake-3.7.1nb1
[918/17510] Failed to build    cmake-3.7.1nb1
[2847/17510] Starting build of  harfbuzz-1.3.4

cmake fails to link because pthread_condattr_setclock() is
undefined.  I see it's present in 7.0.  I guess cmake isn't
catering to its absence?  Is it just me that finds it somewhat
odd that a build tool needs ... esoteric(?) pthread interfaces to

I guess the large jump in the left-hand number indicates how many
packages were skipped in the bulk build as a result...

[2855/17510] Starting build of  gtk2+-2.24.31
[2855/17510] Failed to build    gtk2+-2.24.31
[3927/17510] Starting build of  xmlto-0.0.28nb1

g-ir-scanner fails with what seems like a nonsensical error:

  File "/usr/pkg/lib/python2.7/", line 58, in <module>
    NV_MAGICCONST = 4 * _exp(-0.5)/_sqrt(2.0)
ValueError: math domain error

I never managed to get to the bottom of this one, I looked
briefly at it earlier but didn't get anywhere.  Tried executing
this statement interactively, but then of course it works.

[5078/17510] Starting build of  ruby21-base-2.1.10
[5078/17510] Failed to build    ruby21-base-2.1.10
[5606/17510] Starting build of  p5-HTML-Tagset-3.20nb8

None of the ruby*'s have ever built on powerpc, I think.  It
looks like knowledge of the implementation is required to fix it,
as it appears to be the first use of the "miniruby" which makes
it trip over:

compiling dmyext.c
linking miniruby
./tool/mkconfig.rb:11: [BUG] Segmentation fault
ruby 2.1.10p492 (2016-04-01 revision 54464) [powerpc-netbsd]

-- Control frame information -----------------------------------------------
c:0003 p:---- s:0029 e:000028 CFUNC  :require
c:0002 p:0098 s:0025 E:ffffffffffffefd8 EVAL   ./tool/mkconfig.rb:11 [FINISH]
c:0001 p:0000 s:0002 E:ffffffffffffedd4 TOP    [FINISH]

[3977/17510] Starting build of  ruby22-base-2.2.6
[3977/17510] Failed to build    ruby22-base-2.2.6
[4525/17510] Starting build of  tradcpp-0.5.2nb2

Different build error:

generating encdb.h
./tool/generic_erb.rb:3:in `require': uninitialized stream (IOError)
        from ./tool/generic_erb.rb:3:in `<main>'
*** Error code 1

[4546/17510] Starting build of  ruby23-base-2.3.3
[4546/17510] Failed to build    ruby23-base-2.3.3
[5077/17510] Starting build of  p5-Net-SSLeay-1.78

This one looks similar to the 2.1 one:

compiling dmyenc.c
linking miniruby
generating encdb.h
./tool/generic_erb.rb:3: [BUG] Segmentation fault
ruby 2.3.3p222 (2016-11-21 revision 56859) [powerpc-netbsd]

-- Control frame information -----------------------------------------------
c:0003 p:---- s:0025 e:000024 CFUNC  :require
c:0002 p:0017 s:0021 E:ffffffffffffea3c EVAL   ./tool/generic_erb.rb:3 [FINISH]
c:0001 p:0000 s:0002 E:fffffffffffff818 (none) [FINISH]

[5612/17510] Starting build of  gcc48-4.8.5
[5612/17510] Failed to build    gcc48-4.8.5
[5635/17510] Starting build of  python34-3.4.5nb1

Same here, gcc48 has never built on powerpc, I think.  The build
fails when building genflags.c with redefinition errors:

In file included from ./tm.h:16:0,
                 from ../../gcc-4.8.5/gcc/genflags.c:26:
./options.h:5131:11: error: redefinition of 'OPT_E'
./options.h:4604:11: error: 'OPT_E' previously defined here
./options.h:5133:11: error: redefinition of 'OPT_L'
./options.h:4609:11: error: 'OPT_L' previously defined here

etc. etc.  Besides, I suspect it's missing a lot of the patches
our in-tree gcc has to make it work on powerpc for us, so even if
one got across this first hurdle we'd still not be there.

[5659/17510] Starting build of  gtk3+-3.22.4
[5659/17510] Failed to build    gtk3+-3.22.4
[5765/17510] Starting build of  p5-Test-Pod-1.51nb1

Hm, this one is different from gtk2+:

  CC       gdkapplaunchcontext-x11.lo
In file included from gdkprivate-x11.h:37:0,
                 from gdkapplaunchcontext-x11.c:27:
gdkscreen-x11.h:33:31: error: redefinition of typedef 'GdkX11Monitor'
../../gdk/x11/gdkx11monitor.h:37:36: note: previous declaration of 'GdkX11Monitor' was here

I'm surprised this doesn't pop up elsewhere... (Or does it?)


- Håvard

Home | Main Index | Thread Index | Old Index