pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: upgrading pkgsrc on omnios

* On 2016-11-01 at 16:31 GMT, Geoff Nordli wrote:

> I tried to upgrade pkgsrc using the steps outlined here:
> when I tried to upgrade pkgin it gives me this error:
> root@pc-oi1:~# /opt/local/sbin/pkg_add -U pkgin
> SSL support disabled
> pkg_add: Can't process
>*: Not owner
> pkg_add: no pkg found for 'pkgin', sorry.
> pkg_add: 1 package addition failed
> If I try to do a pkgin update:
> root@pc-oi1:~# /opt/local/bin/pkgin update
> reading local summary...
> processing local summary...
> SSL support disabled
> SSL support disabled
> SSL support disabled
> pkgin: Could not fetch

Hi Geoff,

Apologies, I hadn't updated the illumos instructions to account for
the HTTP -> HTTPS switch.

If you reload the page now you'll see that the instructions have
changed a little, and that there is also a newer bootstrap kit
available (20161020).  This fixes a few issues that were reported
since releasing the first 2016Q3 bootstrap kits.

In order to get back to a working state, first edit this file:


and change the PKG_PATH URL to use "http://"; instead of "https://";.
You should then be able to follow the upgrade instructions.


Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index