pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]



I'm trying to update my PWS500a. Last current NetBSD/alpha runs fine but I have some troubles with mpfr from pkgsrc. Configure script aborts with :

checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether gcc __attribute__ ((mode (XX))) works... yes
checking for recent GMP... yes
checking usable gmp.h at link time... yes
checking for GMP_NUMB_BITS and sizeof(mp_limb_t) consistency... yes
checking for __gmpz_init in -lgmp... yes
checking if gmp.h version and libgmp version are the same... (6.1.0/6.1.0) yes
checking for GMP library vs header correctness... yes
checking for double-to-integer conversion bug... yes or failed to exec (exit status is 191)
configure: error: double-to-integer conversion is incorrect.
You need to use another compiler (or lower the optimization level).
*** Error code 1

make[1]: stopped in /usr/pkgsrc/math/mpfr
*** Error code 1

make: stopped in /usr/pkgsrc/math/mpfr

I use gcc from NetBSD (gcc version 4.8.5 (nb3 20151015). I have tried with gcc 4.9.2 that has been built with an older mpfr version.

Older mpfr releases can be built. I haven't found any information about this issue. I have tried to rebuild mpfr without optimization or specific compiler flag without any success.

	Any idea to build mpfr on NetBSD/alpha ?

	Best regards,


Home | Main Index | Thread Index | Old Index