pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: openjdk7 not compiling with clang

Hi Niclas!

On Thu, Feb 13, 2014 at 03:23:05PM +0100, Niclas Rosenvik wrote:
> Clang doesn't seem to have -fcheck-new, I tried to
> add "BUILDLINK_TRANSFORM+=rm:-fcheck-new" to Makefile 
> in the ".if !empty(PKGSRC_COMPILER:Mclang)" section.
> Clang then finds a bug.
> Adding these changes makes openjdk compile with Clang on my system.
> NetBSD 6.1.2 clang 3.3 from pkgsrc 2013Q4.
> You can try to do the same and see what result you get.

I've tried adding
BUILDLINK_TRANSFORM+=  rm:-fcheck-new
BUILDLINK_TRANSFORM+=  rm:-fpch-deps
to this section. The bug you mention is fixed in the version in pkgsrc.

It builds fine up to this point:

 [pcompile] Generating 3 resource files to 
    [javac] Compiling 72 source files to 
    [javac] Error occurred during initialization of VM
    [javac] Unable to allocate 168KB card tables for parallel garbage 
collection for the requested 2181120KB heap.
    [javac] Error: Could not create the Java Virtual Machine.
    [javac] Error: A fatal exception has occurred. Program will exit.

/scratch/lang/openjdk7/work/openjdk/langtools/make/build.xml:487: The following 
error occurred while executing this line:
/scratch/lang/openjdk7/work/openjdk/langtools/make/build.xml:796: Compile 
failed; see the compiler error output for details.

Total time: 10 seconds
Makefile:201: recipe for target 'build' failed

I don't really wonder that it can't allocate 2GB heap, but I wonder
why it tries...

Home | Main Index | Thread Index | Old Index