pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pbulk build problem?

>>Undefined variables are by definition empty. What shell are you using?
>The root account where this is started uses the default "sh".  The 
>non-privileged account uses "csh".  Is that the problem?  I would have thought 
>the "#!/bin/sh" a the top of the pkg-build script would have over-ridden any 
>user defaults.  Guess if this is the problem it needs to be noted someplace 
>that the non-privileged account used for the bulk builds needs to use "sh" as 
>it's default.

Well, I tried "sh", "csh" and "ksh" for the non-privileged account and all give 
the same results.  Just to make sure it wasn't something else I screwed up in 
my system I built a totally new NetBSD-5.1/i386 system from a 5.1 CD.  Created 
a sandbox, built the pbulk environment as previously described and tried doing 
a builk build.  Same results - "Illegal variable name." no matter what shell I 
used.  Obviously I'm stupidly doing something totally wrong here, but what can 
it be???


Home | Main Index | Thread Index | Old Index