pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: what provides tex metafont mf.base file?

On Thu, 20 May 2010, Pouya D. Tafti wrote:

> On 2010-05-20, Jeremy C. Reed <> wrote:
> [...]
> > \documentclass[english]{scrbook}
> > \usepackage[T1]{fontenc}
> [...]
> With these, I would have expected that Type 1 fonts from
> font/tex-cm-super would be used (and not bitmap ones).  I would try
> updating that package,

I didn't have that installed. As far as I can tell nothing depended on 

Now I installed it and those problems are gone!


> and perhaps running (as root) texhash and
> updmap-sys to update map files (but I still don't understand why
> mf.base cannot be created!).

Before I installed tex-cm-super I ran texhash and updmap-sys as root, 
but that didn't help.

> Otherwise, would it be possible for you to list the other packages
> used in your document?

(skipped this for now)

>  Also, what version of print/tex-pdftex are you using (IIRC it 
> provides


> Last thing, what happens if you run mktexpk as root (with the
> arguments listed in your post)?

I also tried that. Same error.

When I upgraded my kpathsea-5.0.0nb2 and web2c-7.5.7nb5 to
kpathsea-5.0.0nb3 and web2c-2009, I started getting an additional error:

fmtutil: format directory '/home/reed/.texlive2009/texmf-var/web2c' does 
not exist.

I created it. Then had new error where .texlive2009 was not writable -- 
somehow it had been owned by root. (I guess by running one of the tools 
as root.) I changed ownership to me and ran "fmtutil --all" and many 
files were populated there. But problem continued.

When I move my .texlive2009 out of the way I get:

This is pdfTeX, Version 3.1415926-1.40.10 (Web2C 2009)
 restricted \write18 enabled.
---! /var/lib/texmf/web2c/pdftex/pdflatex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

So I moved it back.  But at least my problem is fixed.  Thanks.

Home | Main Index | Thread Index | Old Index