Subject: can't compile print/libgnomeprint on NetBSD/amd64
To: None <>
From: Hiroyuki Bessho <>
List: pkgsrc-users
Date: 06/28/2007 03:02:55
I had a problem to compile libgnomeprint package on NetBSD/amd64 4.0_BETA2.
I tried it on two amd64 machines and got same result.  The package 
compiled cleanly on NetBSD/i386.

Has anyone had same problem?

*** Rebuilding template files ***
cd . && gtkdoc-mktmpl --module=libgnomeprint
WARNING: 480 unused declarations.
   These can be found in libgnomeprint-unused.txt.
   They should be added to libgnomeprint-sections.txt in the appropriate 
touch tmpl-build.stamp
*** Building XML ***
cd . && \
     gtkdoc-mkdb --module=libgnomeprint --source-dir=../../libgnomeprint 
--output-format=xml --sgml-mode
55% symbol docs coverage (146 symbols documented, 26 symbols incomplete, 
120 not documented)
See libgnomeprint-undocumented.txt for a list of missing docs.
The doc coverage percentage doesn't include intro sections.
touch sgml-build.stamp
*** Building HTML ***
rm -rf ./html
mkdir ./html
cd ./html && gtkdoc-mkhtml libgnomeprint ../libgnomeprint-docs.sgml
error : Memory allocation failed : copying node
[1]   Segmentation fault (core dumped) /usr/pkg/bin/xsl...
gmake[3]: *** [html-build.stamp] Error 139
gmake[3]: Leaving directory 
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory 
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory 
gmake: *** [all] Error 2
*** Error code 2

make: stopped in /u0/pkgsrc/2007Q1/print/libgnomeprint
*** Error code 1

make: stopped in /u0/pkgsrc/2007Q1/print/libgnomeprint

A full compile log is at