pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: pkgsrc/www/webkit-gtk

Module Name:    pkgsrc
Committed By:   gutteridge
Date:           Thu Jan 13 03:57:28 UTC 2022

Modified Files:
        pkgsrc/www/webkit-gtk: Makefile

Log Message:
webkit-gtk: fix builds on NetBSD 9.x

The base GCC 7.5 on NetBSD 9.x is missing a C++17 feature expected by
this package now. The pkgsrc GCC 7.5 includes that feature, but the
build still fails later on with another unmet expectation. So GCC 8 is
now the minimum viable version with which to build this package.

This involves a bit of a kludge to deal with how GCC from pkgsrc ends
up linking. This is obviously not ideal, and is part of a broader
topic that needs revisiting. The present goal is to try and stabilize
the 2021Q4 branch.

Tested on 9.2_STABLE/amd64 with www/badwolf. Addresses PR pkg/56604.

To generate a diff of this commit:
cvs rdiff -u -r1.218 -r1.219 pkgsrc/www/webkit-gtk/Makefile
cvs rdiff -u -r1.86 -r1.87 pkgsrc/www/webkit-gtk/

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

Modified files:

Index: pkgsrc/www/webkit-gtk/Makefile
diff -u pkgsrc/www/webkit-gtk/Makefile:1.218 pkgsrc/www/webkit-gtk/Makefile:1.219
--- pkgsrc/www/webkit-gtk/Makefile:1.218        Wed Dec 29 08:59:16 2021
+++ pkgsrc/www/webkit-gtk/Makefile      Thu Jan 13 03:57:27 2022
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.218 2021/12/29 08:59:16 leot Exp $
+# $NetBSD: Makefile,v 1.219 2022/01/13 03:57:27 gutteridge Exp $
 DISTNAME=      webkitgtk-2.34.3
 PKGNAME=       ${DISTNAME:S/webkitgtk/webkit-gtk/}
@@ -19,16 +19,27 @@ TOOL_DEPENDS+=      gettext-tools>=0.18:../..
 TOOL_DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
 USE_CMAKE=     yes
 USE_TOOLS+=    automake bash bison flex gmake perl pkg-config msgfmt
 # Enabling -gdwarf-2 hits GNU ar limits on file size.
-# GCC >= 7.3.0 is required, checked via CMakeLists.txt
-GCC_REQD+=             7
+# GCC >= 8 is required, it no longer builds with lower versions.
+GCC_REQD+=             8
 USE_GCC_RUNTIME=       yes
+.include "../../mk/"
+# This package will link against from the pkgsrc GCC when the
+# base OS GCC doesn't meet the minimum requirement. Thus we do this so the
+# appropriate gcc-libs package will be captured as a dependency, otherwise
+# binary packages will be broken. See also PR pkg/56604.
+.if ${OPSYS} == "NetBSD" && ${OPSYS_VERSION} < 099915
+USE_PKGSRC_GCC=                yes
 # Using subverts Pkgsrc wrappers, and this package also crashes buggy
 # versions of

Index: pkgsrc/www/webkit-gtk/
diff -u pkgsrc/www/webkit-gtk/ pkgsrc/www/webkit-gtk/
--- pkgsrc/www/webkit-gtk/    Wed Dec 29 08:59:16 2021
+++ pkgsrc/www/webkit-gtk/ Thu Jan 13 03:57:27 2022
@@ -1,4 +1,4 @@
-# $NetBSD:,v 1.86 2021/12/29 08:59:16 leot Exp $
+# $NetBSD:,v 1.87 2022/01/13 03:57:27 gutteridge Exp $
 BUILDLINK_TREE+=       webkit-gtk
@@ -10,7 +10,7 @@ BUILDLINK_ABI_DEPENDS.webkit-gtk?=    webki
 BUILDLINK_PKGSRCDIR.webkit-gtk?=       ../../www/webkit-gtk
 # This is necessary to match the package requirement.
-GCC_REQD+=     7.3
+GCC_REQD+=     8
 pkgbase := webkit-gtk
 .include "../../mk/"

Home | Main Index | Thread Index | Old Index