Subject: pkg/36861: shared-mime-info doesn't build anymore
To: None <,,>
From: None <>
List: pkgsrc-bugs
Date: 08/30/2007 05:25:00
>Number:         36861
>Category:       pkg
>Synopsis:       shared-mime-info doesn't build anymore preventing build of GNOME
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Aug 30 05:25:00 +0000 2007
>Originator: Root
>Release:        NetBSD 3.1
Gravier Family
System: NetBSD mailhost 3.1 NetBSD 3.1 (MAILHOST) #0: Fri May 25 13:28:50 CEST 2007 root@mailhost:/usr/src/sys/arch/i386/compile/MAILHOST i386
Architecture: i386
Machine: i386
	After reboot of my machine, GNOME-SESSION wasn't present anymore. Tried a rebuild... but shared-mime-info fails to build with following error:

INTLTOOL_EXTRACT=../intltool-extract srcdir=. ../intltool-update --gettext-package shared-mime-info --pot
WARNING: This version of gettext does not support extracting non-ASCII
         strings. That means you should install a version of gettext
         that supports non-ASCII strings (such as GNU gettext >= 0.12),
         or have to let non-ASCII strings untranslated. (If there is any)
xgettext: unrecognized option `--flag=g_strdup_printf:1:c-format'
Try `xgettext --help' for more information.
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
gmake[1]: *** [shared-mime-info.pot] Error 1
gmake[1]: Leaving directory `/usr/pkgsrc/databases/shared-mime-info/work/shared-mime-info-0.19/po'
gmake: *** [check-recursive] Error 1

	cd /usr/pkgsrc/databases/shared-mime-info
	No idea.
	I tried to install gettext from pkgsrc, but that didn't fix things.