Subject: Re: Cups authentication
To: None <netbsd-users@NetBSD.ORG>
From: MLH <>
List: netbsd-users
Date: 11/14/2002 16:41:13
On 14 Nov 2002 04:15:01 -0600, Julio Merino wrote:
> On Thu, 14 Nov 2002 00:44:29 +0100
> Quentin Garnier <> wrote:
>> When I tried to make cups work on my system, I had to make it listen on a
>> port different from 631. I ended up setting 6311, on which I get
>> authentification working properly.
> Thanks for the tip, but no luck. I can't access.

Also, did you try another browser? I noticed that the cups server
didn't work with several browsers.

>> But since I could never make it use my parallel printer, I gave up on
>> cups.
> Uh :( I also had this problem some time ago (when cups worked). I was unable
> to solve it under NetBSD. Though I saw this behavior in FreeBSD (not showing
> the lpt in the configuration); booting the system with the printer up made
> it detect the parallel port. (this trick does not work in netbsd).

I got cups to work with lpa0 but never could get it to work with
lpt0 even though lpt0 worked fine with my previous printer.  That
might be a cable problem however.

> Well, I think I'll go with lpd+apsfilter+ghostscript+hpijs and see if it
> works fine.

I got cups to work from the browser interface but not a single one
of the lp/lpr replacements will work. I finally ditched cups and
wrote a magicfilter filter for the printer (pcl6/gdi laser) and am
using the usb interface, though if I turn the printer off and then
back on :

Nov 14 08:05:02 tiamat /netbsd: ulpt0: at uhub1 port 1 (addr 2) disconnected
Nov 14 08:05:02 tiamat /netbsd: ulpt0 detached
Nov 14 08:11:51 tiamat /netbsd: uhub1: device problem, disabling port 1

Is there a way to re-enable the printer once this has been done?
Seems that I have to reboot to get the printer back online.

>> I guess there's a consensus.
> Yes :p But as I said, it worked before. Something got broken in some update,
> I guess.

I'm running NetBSD 1.6J. Updated in order to try ulpt0.