NetBSD-Ports archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Installing on Loongson2f causing sysinst segmentation fault


I'm trying to install NetBSD onto my Loongson2f netbook and when
partitioning the disk sysinst will crash due to segmentation fault.
The exact error message looks like below:

[ 104.2026388] uid 0, pid 16, command sysinst, on /: file system full
[ 104.2397136] /: write failed, file system is full
[ 104.2597050] pid 16 (sysinst): user write of 139472@0x78594000 at
730572 failed: 28

This error showed up whenever I tried to change the partition map and
mark the NetBSD partition active.  I have previously installed OpenBSD
on the Loongson2f netbook so I have one ext2 partition of 2G as boot
drive for the kernels and the rest of the disk (~158G) as OpenBSD file
system.  I have tried the following:
* Remove the OpenBSD file system and create a NetBSD fs.
* Directly change the OpenBSD fs to NetBSD fs.
* Remove everything and recreate the ext2 fs and NetBSD fs.
And all attempts ended up in sysinst segfault when trying to mark the
NetBSD partition active.  There were obviously enough space on my
disk, so I suspect this file system full error maybe referring to the
installer ramfs?

I've tried both the NetBSD 9.2-release and NetBSD daily snapshot but
both ended up in this error.  As I don't have a working NetBSD system
yet I cannot use sendbug with system info, so do let me know if you
need any more info.  Any fix or workaround are appreciated!

Thanks in advance.

Home | Main Index | Thread Index | Old Index