NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/56949: CWM can't bind keys because it looks for a wrong path

>Number:         56949
>Category:       bin
>Synopsis:       CWM can't bind keys because it looks for a wrong path
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Aug 02 17:45:00 +0000 2022
>Originator:     vms
>Release:        9.2
NetBSD localhost 9.2 NetBSD 9.2 (GENERIC) #0: Wed May 12 13:15:55 UTC 2021 amd64

CWM the window manager from OpenBSD has a .cwmrc file to configure it.

When trying to use bind-key the window manager won't take any effect.

You can unbind keys and set all other options, but bind-key won't work.

By looking at the man page of cwmrc it shows what the bug is.

     bind-key key function
             Bind or rebind key key to function.  The modifier keys come
             first, followed by a `-', then a keysym name, taken from

As you can see it tries to find keysymdef.h in X11R6 which obviously does not exist because it should be X11R7. 

You guys have to somehow change that path, I've fixed it by making that path exist and copying the keysymdef.h there.

So now I have /usr/X11R6/include/X11/keysymdef.h in my machine and cwm is able to find it so now it works.

Install cwm, try to bind any key with .cwmrc like

bind-key 4-n /usr/pkg/bin/firefox

it won't work
change the path of X11R6 to X11R7, my fix was to make that path exist, but obviously it's a bad fix, you'll have to look at the code where this path is being searched and update it.

Home | Main Index | Thread Index | Old Index