NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: install/56213: 9.2 UEFI boot from USB image fails on HP DL380 G6

The following reply was made to PR install/56213; it has been noted by GNATS.

From: "David H. Gutteridge" <>
Subject: Re: install/56213: 9.2 UEFI boot from USB image fails on HP DL380 G6
Date: Wed, 23 Jun 2021 22:15:08 -0400

 I added debugging code at various points, and tested it on more than one
 machine, to see what would happen.
 The failure is happening in boot1.c, when it makes the consecutive
 open() calls. It tries the first two possibilities, they both fail, the
 next if block tests also fail ("fallback on partition 'a' from the
 disklabel"), so it doesn't try any further.
 Then I tried the 9.0 MBR installer image, added the same debugging code
 there, and found it succeeds at the first open() call in that case. (I
 wanted to see if it fell through to the "fallback on partition 'a' from
 the disklabel" case).
 I also looked through the code to see how it changed over time, in case
 there was a clue there, but I didn't see anything. But I'm out of my
 depths here, so who knows.
 Then I decided to try the "merged" installer on yet another laptop I
 hadn't tried at all before. It also failed to work there, but gave a
 completely different error message: "Invalid partition table!" (Which
 I think is coming from its BIOS, not our code.) The 9.0 MBR installer
 worked fine on it, though. So I'm wondering if there are weird firmwares
 that get confused by the mere presence of EFI content.

Home | Main Index | Thread Index | Old Index