NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-evbarm/55894: installboot overwrites primary GPT

>Number:         55894
>Category:       port-evbarm
>Synopsis:       installboot overwrites primary GPT
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    port-evbarm-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Dec 25 12:35:00 +0000 2020
>Originator:     Benny Siegert
>Release:        NetBSD 9.99.74
The NetBSD Foundation
NetBSD 9.99.74 with an older -current userland.
Pine A64-LTS, running evbarm-aarch64.
I added an eMMC module to the Pine A64 and have been trying to transfer
my existing NetBSD installation over from the SD card. The part where
things go wrong is when installing U-Boot.

I created a GPT with an EFI partition, a root and swap partition.
I first tried to install the bootloader with the following command that
I found on the wiki:

dd if=u-boot-sunxi-with-spl.bin of=/dev/rld1c bs=1k seek=1 conv=sync

However, that overwrites the primary GPT, since the GPT extends beyond
the 8 KB skipped.

Next (after "gpt recover"), I tried using installboot:

installboot -v ld1

The -v parameter produces so much output that I did not quite see what
actually happened. However, the GPT (primary copy) is also overwritten
by installboot.

At reboot, you can see U-Boot come up over the serial console and then
fail to find any partitions.
installboot -v ld1
I don't know, however I would very much like to be able to boot from the
eMMC drive with GPT :)

Home | Main Index | Thread Index | Old Index