NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/55006: unavoidable boot lockup and SpeedStep crash on ThinkPad W540

>Number:         55006
>Category:       port-amd64
>Synopsis:       unavoidable boot lockup and SpeedStep crash on ThinkPad W540
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Feb 22 20:55:00 +0000 2020
>Originator:     Jackson Bryn
>Release:        9.0
Can not input
This report describes two problems that both cause the system to be unable to boot. One of which can be worked around, and one of which can not, resulting in the system still being unable to boot regardless.

Happens when SpeedStep is enabled in BIOS. Kernel output slows down to a crawl, and the kernel itself crashes on enabling acpiecdt. In MBR mode, this causes an automatic restart, no jump to kernel debugger. In UEFI mode, however, the kernel succeeds in jumping to the debugger, and thus I can retrieve this:

Stopped in pid 0.1 (system) atfatal double fault in supervisor mode
[   1.0000030] trap type 13 code 0 rip 0xffffffff80223eb2 cs 0x8 rflags 0x10282 cr2 0xffffff0000001fc8 ilevel 0x8 rsp 0xffffff0000001fd0
[   1.0000030] curlwp 0xffffffff8145ce80 pid 0.1 lowest kstack 0xffffffff818e62c0
  kernel: double fault trap, code=0

Note that I used the non-ASLR kernel! Continuing on, I can not get to the debugger prompt and trace the issue, however, as the debugger log keeps repeating this ad infinitum.

To work around the issue, simply disable SpeedStep in BIOS. The kernel will get through and everything goes fine... until the root device search procedure; this leads to my next problem.

When the kernel begins to search for the root device, it... locks up. This is not an issue with the USB device driver, as I have disabled that and the problem still shows up.

On both MBR and UEFI mode, when the kernel locks up, there is no jump to debugger or an automatic restart. I have tried to enable/disable the suspected culprits in BIOS, but alas, I could not find anything that caused it. I need further guidance.

For those who can view images, this is where the kernel locks up at:
Apologies for the unprofessional image host.
Reproducing SpeedStep Crash:
1. Enable SpeedStep in BIOS.
2. Boot NetBSD normally.
3. Watch NetBSD crash when detecting acpiecdt.

Reproducing Boot Lockup:
1. Disable SpeedStep to avoid problem above.
2. Boot NetBSD normally.
3. Watch NetBSD hang.

Home | Main Index | Thread Index | Old Index