NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/54988: possible memory leaks/swap problems

>Number:         54988
>Category:       port-amd64
>Synopsis:       system freezes shortly after physical memory is exhausted.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 19 18:30:00 +0000 2020
>Originator:     mlh
>Release:        NetBSD 9.99.46 Thu Feb 13 13:00:32 EST 2020
System: NetBSD tiamat 9.99.46 NetBSD 9.99.46 (HDMIAUDIO) #0: Thu Feb 13 13:00:32 EST 2020 mlh@tiamat:/opt/obj/amd64/opt/src/sys/arch/amd64/compile/HDMIAUDIO amd64
Architecture: x86_64
Machine: amd64
When doing simple build operations such as a csv update + building
a std distribution, physical memory is exhausted fairly quickly and
appears to not be returned and when physical mem is exhausted, the
system simply freezes as though something is wrong with swap operations.
I have tried using several different swap partitions and from different
disks but it doesn't appear to change the result. I have 4G of physical
memory and I can't even finish building a std distribution without
having to cycle power to reboot in order to contiune. I can cause the
problem to occur within a few minutes by using pkg_chk to load a list
of prebuilt binary pkgsrc packages. It freezes before even 300 packages
are loaded. It might be a problem with disk cache operations but
not sure. Sometimes phy mem appears to be exhausted by application
but it can happen when application use is only around 20% and the
remainder is disk cache, as with loading binary packages. I can stop the
task before phy mem is exhausted but I see no evidence that any
appreciable amount of memory consumed is ever returned. I can stop when
vmstat fre shows down to around 20000 and until I reboot, free memory
stays pretty much at that point. I can even shut down X and most else
and still very little memory is available.
-current as of the last couple of weeks (that I have tried) behaves this way.
Build from late Jan worked fine.

$ cd /usr/src
$ cvs up
$ /usr/src/ -j2 -x -r -U -u -m amd64 -D /opt/obj/amd64/build -M /opt/obj/amd64 -T /opt/obj/amd64/tools -R /opt/build/9 tools release

Home | Main Index | Thread Index | Old Index