NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-sparc64/54211: esiop stopped detecting boot disk

On Fri, 17 May 2019, wrote:

I'm having problems with (from the looks of it) esiop again. Couple of days ago I
wasted Martins time with a disk problem on Ultra 60 which resolved itself magically,
now it's back on another machine. I'm getting slightly paranoid here.

Upgraded the machine from .29. Now the boot disk isn't recognized at all.
Cold boot, warm boot, doesn't matter. I can hear it spin down at
[   1.9139548] scsibus0: waiting 2 seconds for devices.

  Has there been any change in this?

I was playing with my Ultra 45 systems again, and tried updating to NetBSD 9.0_BETA, and am seeing the same kind of behaviour, except with mpt. My 8.1_STABLE system works fine (although I have to increase the kernel stack size to get through the boot).

I noticed that sparc64 switched from gcc6 to gcc7 back in Februrary, so my first wild guess is something in gcc7 may be causing the problem. There were no noticable changes in the mpt code between NetBSD-8 and NetBSD-9, so I don't know if the problem is in the mpt code, or something else it uses.

I will probably try this again with an older tree that still has gcc6 and I can try with both versions). I was doing that a year ago when I was having trouble with the Ultra 45 crashing while configuring the audio driver.

I had also tried a current autobuild kernel, which fails in the same way, but also does not crash in the audio driver.


Michael L. Hitch              
Operations Consulting,  University Information Technology
Montana State University, Bozeman, MT     USA

Home | Main Index | Thread Index | Old Index